clear query| facets| time Search criteria: .   Results from 1 to 10 from 84 (0.0s).
Loading phrases to help you
refine your search...
[FLUME-2957] Remove Guava from our public API - Flume - [issue]
...Context.getParameters (flume-ng-configuration module) returns com.google.common.collect.ImmutableMap (Guava). We should clean our API and return either a native java interface or Flume's.In ...
http://issues.apache.org/jira/browse/FLUME-2957    Author: Lior Zeno , 2018-02-06, 11:29
[FLUME-2921] Support Elasticsearch 2.0+ - Flume - [issue]
...Elasticsearch sink supports an ancient version of ES. We should make the sink work with newer versions of Elasticsearch.I attached a patch for that. Please note that this involves upgrading ...
http://issues.apache.org/jira/browse/FLUME-2921    Author: Lior Zeno , 2018-01-23, 19:34
[FLUME-2938] JDBC Source - Flume - [issue]
...The idea is to allow migrating data from SQL stores to NoSQL stores or HDFS for archiving purposes.This source will get a statement to execute and a scheduling policy. It will be able to fet...
http://issues.apache.org/jira/browse/FLUME-2938    Author: Lior Zeno , 2017-09-12, 13:35
[FLUME-2944] Remove guava as dependency - Flume - [issue]
...Guava is a very popular dependency, which often causes version collisions. Especially, due to lack of backwards compatibility. Adding new dependencies that rely on guava requires us to shade...
http://issues.apache.org/jira/browse/FLUME-2944    Author: Lior Zeno , 2017-09-12, 13:35
[FLUME-2943] Integrate checkstyle - second pass - Flume - [issue]
...In the first phase of this task we used a weakened style rules. This issue proposes to add the following rules: Naming conventions Java docs (relaxed version) Disallowing static star imports...
http://issues.apache.org/jira/browse/FLUME-2943    Author: Lior Zeno , 2017-09-12, 13:23
[FLUME-2936] KafkaSource tests arbitrarily fail - Flume - [issue]
...KafkaSource tests are flaky, and tend to fail. I investigated this issue and discovered the following issues: KafkaSource hangs in doStart at line 413:KafkaSourceEmbeddedKafka.java it =...
http://issues.apache.org/jira/browse/FLUME-2936    Author: Lior Zeno , 2017-08-13, 12:56
[FLUME-2945] Bump java target version to 1.8 - Flume - [issue]
...We should move to Java 8 as a minimum requirement. Java 7 is EOL'ed http://www.oracle.com/technetwork/java/eol-135779.html. Many projects are adopting java 8 as a minimum requirement, for in...
http://issues.apache.org/jira/browse/FLUME-2945    Author: Lior Zeno , 2017-06-21, 15:14
[expand - 1 more] - make junit tests passing again - Flume - [mail # dev]
...We have another one:testMinimumRequiredSpaceTooSmallForPut(org.apache.flume.channel.file.TestLog).Seehttps://builds.apache.org/job/Flume-trunk-hbase-1/220/org.apache.flume.flume-ng-channels$...
   Author: Lior Zeno , 2016-10-24, 15:02
[expand - 2 more] - Migrate to Log4j 2 - Flume - [mail # dev]
...Sure, point taken. The only issue is having both versions in the samebinary. But it's not the case here.I am not sure of it is a good practice to continue supporting deprecatedsoftware, but ...
   Author: Lior Zeno , 2016-10-21, 22:51
[expand - 4 more] - Enabling Travis-CI on Flume - Flume - [mail # dev]
...Mike, I was not holding Donat back. I was just suggesting ways to configureJenins, per Donat's request. I'm sorry if my former post delivered thewrong message.On Fri, Oct 21, 2016 at 6:29 PM...
   Author: Lior Zeno , 2016-10-21, 15:44