Subject: [ansible-devel] New Ansible release, 2.8.0rc1


Hi all- we're happy to announce that the general release of Ansible
2.8.0rc1 is now available!
How do you get it?
------------------

$ pip install ansible==2.8.0rc1 --user

The tar.gz of the release can be found here:

* 2.8.0rc1
  https://releases.ansible.com/ansible/ansible-2.8.0rc1.tar.gz
  SHA256: c17cda1be39a2b89df76e54038c90849f090991146b22ce602ddd8a344f61f11
What's new in 2.8.0rc1
----------------------

This release is a prerelease of Ansible 2.8.0 that contains numerous
bugfixes over 2.8.0 beta1.  There are two notable changes:

* We found a minor security issue in the python interpreter discovery
feature introduced in alpha1.  That has been fixed by marking the
discovered interpreter path as non-templatable so that jinja2 would
not recursively template it.

* We realized after beta1 that several gcp modules were supposed to be
deprecated for 2.8.0 but the maintainer needed help from the Ansible
Core devs to merge the deprecation notices.  We decided that even
though it was after beta, the best thing to do would be to go ahead
and deprecate those now.  As such, the following modules will start
issuing deprecation warnings in rc1 where they did not complain in
beta1.

* gcspanner use gcp_spanner_instance instead.
* gcdns_record use gcp_dns_resource_record_set instead.
* gcdns_zone use gcp_dns_managed_zone instead.
* gcp_forwarding_rule use gcp_compute_global_forwarding_rule
or gcp_compute_forwarding_rule instead.
* gcp_healthcheck use gcp_compute_health_check,
gcp_compute_http_health_check, or gcp_compute_https_health_check
instead.
* gcp_backend_service use gcp_compute_backend_service instead.
* gcp_target_proxy use gcp_compute_target_proxy instead.
* gcp_url_map use gcp_compute_url_map instead.

The full changelog is at:

* 2.8.0rc1
  https://github.com/ansible/ansible/blob/stable-2.8/changelogs/CHANGELOG-v2.8.rst
What's the schedule for the rest of 2.8.0?
----------------------------------------------------

2.8.0 final is expected on 2019-05-16.  We have scheduled time to
issue up to two more release candidates between now and then if we
discover any blocker bugs.  If no blockers are discovered, the code in
rc1 will be what ships in the 2.8.0 final release.  You can look at
the 2.8 roadmap document for more details:

https://docs.ansible.com/ansible/devel/roadmap/ROADMAP_2_8.html
Porting Help
------------

We've published a porting guide at
https://docs.ansible.com/ansible/devel/porting_guides/porting_guide_2.8.html
to help migrate your content to 2.8.
If you discover any errors or if any of your working playbooks break when you
upgrade to 2.8.0rc1, please use the following link to report the regression:

  https://github.com/ansible/ansible/issues/new/choose

In your issue, be sure to mention the Ansible version that works and the one
that doesn't.

Thanks!

-Toshio Kuratomi

--