@Anup, it should. If it isn't back compatible, it is a Hive issue.

Hive Trift Metastore API was changed, but still isn't documented in
cwiki.apache.org [1]
*hive.metastore.client.capability.check *[2] property is true by default.
Possibly changing this could help you.
You can change it in Drill Hive plugin or in hive-site.xml
Looks like, the issue will be the same for using hive-server2 2.3 version
and hive-metastore 2.1 version. If so it is a Hive issue.

So you can try to change the property before updating to Hive 2.3 version.

[1] https://issues.apache.org/jira/browse/HIVE-15062
[2]
https://issues.apache.org/jira/browse/HIVE-15062?focusedCommentId=15659298&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15659298

Kind regards
Vitalii

On Tue, Mar 20, 2018 at 1:54 PM, Anup Tiwari <[EMAIL PROTECTED]>
wrote: