I agree we have to upgrade our es version.  Thanks for your help on this.

---