Subject: Re: [DISCUSS] KIP-479: Add Materialized to Join


Thanks Bill!

Using a new configuration object was suggested by John in the original
DISCUSS thread already. We rejected it because we wanted to avoid a new
configuration class. However, given your analysis, it seems it's
actually the right choice to introduce a new configuration class.

Hence, overall I am +1 on the proposal.
Some nits about names (as always :))

- `StreamJoined.as()` does not sound right for the `StoreSupplier`
overload. Maybe it's better to call that static method `with` (not 100%
sure)

- Should we use plural instead of singular -> `Stream{s}Joined`
  -> or keep singular but call it `StreamJoin`
  `Joined` seems to refer to the input stream(s) while `Join` would
refer to the join-operator

Thoughts?
You suggest to deprecate existing overload what I support -- can you
list deprecated method in the "Public Interface" section?

-Matthias

On 9/17/19 9:39 AM, Guozhang Wang wrote:
Comment: GPGTools - https://gpgtools.org

iQIzBAEBCgAdFiEE8osu2CcCCF5douGQu8PBaGu5w1EFAl2BJDgACgkQu8PBaGu5
w1Ew+g/6AtXdy9C8HO3NhVhsfpgn0L5wl7atydNN8CWoRqJU5Vetc2jcM9q4cEoZ
DevCsy6LG3IE9jsgA6nRZOe5WiAomKxVdLNA2HvJvuCQfN79MqofhOasb51HXCpw
p1XlUUtXVsK9MDpBj1rZHBuyHsiyehiEyIRiTrOV1L/1HUrRhRhgGMoBk+KMxwdE
SP+Jhpkf4oGhZigxFM11NvVU+v/oTZxRGRllUk32LQTXFuNPc7DRq37h1A33DKFW
JZQQ8F7XFYkLb4J7xQOvDtDJ8hiaI9vQLed1ykU8DHiiYC8YQ9Cn5ZKUU74oFZm9
BgnTtIdOyNS3B9dM4ATTrl46N+LOUZLqORmdJ33qkiBNVRFnFUunKb6dT1SKNQv/
L03ASyD06earK+tUEeuDqkyV78YY8mEVkKvcYgNgwoyro89jRCxv/Boel1re330O
a4ldQX3AdUSfd98qC7QIWc7sdv+q4gMX9/Pa/n3dzRgTuTl1yvOfLT9G3wF6Eoes
e7isvaPobO+2fyff+ET69UJ+nK1P7uH6AHrEo3j+8PRkc2j3/aAl8Q02saX6i4cJ
rWUfp4MoMvA0HBzehIrPWVGLV8fKqcgJ+3KtkBefKr1z4PgCiEDOY+qN21WjayO1
86AVqS88p2K02jS3w6jZrXzwtuzcWxxIgHcoIwB+CA0sh6deOG4=
=hFtN