Hi,

I am failing to install ambari metrics... as bunch of yum errors comes up.
I tried cleaning up yum duplicates  but no wane. I can confirm that bare
metal Installaton documantion  is out date, I can help update if once. I
get ride of such problem

package-cleanup --dupes

stderr:
Traceback (most recent call last):
  File
"/var/lib/ambari-agent/cache/common-services/AMBARI_METRICS/0.1.0/package/scripts/metrics_collector.py",
line 148, in <module>
    AmsCollector().execute()
  File
"/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 285, in execute
    method(env)
  File
"/var/lib/ambari-agent/cache/common-services/AMBARI_METRICS/0.1.0/package/scripts/metrics_collector.py",
line 36, in install
    self.install_packages(env)
  File
"/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 576, in install_packages
    retry_count=agent_stack_retry_count)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py",
line 155, in __init__
    self.env.run()
  File
"/usr/lib/python2.6/site-packages/resource_management/core/environment.py",
line 160, in run
    self.run_action(resource, action)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/environment.py",
line 124, in run_action
    provider_action()
  File
"/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 54, in action_install
    self.install_package(package_name, self.resource.use_repos,
self.resource.skip_repos)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py",
line 51, in install_package
    self.checked_call_with_retries(cmd, sudo=True,
logoutput=self.get_logoutput())
  File
"/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 86, in checked_call_with_retries
    return self._call_with_retries(cmd, is_checked=True, **kwargs)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 98, in _call_with_retries
    code, out = func(cmd, **kwargs)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
70, in inner
    result = function(command, **kwargs)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
92, in checked_call
    tries=tries, try_sleep=try_sleep)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
140, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File
"/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
293, in _call
    raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of
'/usr/bin/yum -d 0 -e 0 -y install ambari-metrics-monitor' returned 1.
Error: python-devel conflicts with python-2.7.5-34.el7.x86_64
 You could try using --skip-broken to work around the problem
** Found 625 pre-existing rpmdb problem(s), 'yum check' output follows:
ModemManager-glib-1.6.0-2.el7.x86_64 is a duplicate with
ModemManager-glib-1.1.0-8.git20130913.el7.x86_64
1:NetworkManager-1.8.0-11.el7_4.x86_64 is a duplicate with
1:NetworkManager-1.0.6-27.el7.x86_64
1:NetworkManager-adsl-1.8.0-11.el7_4.x86_64 is a duplicate with
1:NetworkManager-adsl-1.0.6-27.el7.x86_64
1:NetworkManager-glib-1.8.0-11.el7_4.x86_64 has installed conflicts
NetworkManager-libnm < ('1', '1.8.0', '11.el7_4'):
1:NetworkManager-libnm-1.0.6-27.el7.x86_64
1:NetworkManager-glib-1.8.0-11.el7_4.x86_64 is a duplicate with
1:NetworkManager-glib-1.0.6-27.el7.x86_64
1:NetworkManager-libnm-1.8.0-11.el7_4.x86_64 has installed conflicts
NetworkManager-glib < ('1', '1.8.0', '11.el7_4'):
1:NetworkManager-glib-1.0.6-27.el7.x86_64
1:NetworkManager-libnm-1.8.0-11.el7_4.x86_64 is a duplicate with
1:NetworkManager-libnm-1.0.6-27.el7.x86_64
1:NetworkManager-team-1.8.0-11.el7_4.x86_64 is a duplicate with
1:NetworkManager-team-1.0.6-27.el7.x86_64
1:NetworkManager-wwan-1.8.0-11.el7_4.x86_64 is a duplicate with
1:NetworkManager-wwan-1.0.6-27.el7.x86_64
abattis-cantarell-fonts-0.0.25-1.el7.noarch is a duplicate with
abattis-cantarell-fonts-0.0.16-3.el7.noarch
abrt-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-2.1.11-36.el7.centos.x86_64
abrt-addon-ccpp-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-addon-ccpp-2.1.11-36.el7.centos.x86_64
abrt-addon-kerneloops-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-addon-kerneloops-2.1.11-36.el7.centos.x86_64
abrt-addon-pstoreoops-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-addon-pstoreoops-2.1.11-36.el7.centos.x86_64
abrt-addon-python-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-addon-python-2.1.11-36.el7.centos.x86_64
abrt-addon-vmcore-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-addon-vmcore-2.1.11-36.el7.centos.x86_64
abrt-addon-xorg-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-addon-xorg-2.1.11-36.el7.centos.x86_64
abrt-cli-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-cli-2.1.11-36.el7.centos.x86_64
abrt-console-notification-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-console-notification-2.1.11-36.el7.centos.x86_64
abrt-dbus-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-dbus-2.1.11-36.el7.centos.x86_64
abrt-libs-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-libs-2.1.11-36.el7.centos.x86_64
abrt-python-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-python-2.1.11-36.el7.centos.x86_64
abrt-retrace-client-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-retrace-client-2.1.11-36.el7.centos.x86_64
abrt-tui-2.1.11-48.el7.centos.x86_64 is a duplicate with
abrt-tui-2.1.11-36.el7.centos.x86_64
accountsservice-0.6.45-3.el7_4.1.x86_64 is a duplicate with
accountsservice-0.6.35-9.el7.x86_64
accountsservice-libs-0.6.45-3.el7_4.1.x86_64 is a duplicate with
accountsservice-libs-0.6.35-9.el7.x86_64
adwaita-cursor-theme-3.22.0-1.el7.noarch is a duplicate with
adwaita-cursor-theme-3.14.1-1.el7.noarch
adwaita-gtk2-theme-3.22.2-1.el