> JCC monkeypatches as needed.

I don't think monkey patching worked on Ubuntu 18.04, for any version of
JCC that I tried. When running make, I ran into errors discussing how JCC
was not built with shared support.

> Does Lucene 4 even build and run with Java 11 ?

No idea. I halted my efforts once I got PyLucene 4.10.1 working with
openjdk-8-jdk.