Subject: Java agent & OAP server version match question


Hi

The javaagent is compatible with the backend for all 6.x releases, even the
next 7.0.0. So, you don't need to worry about that part.
SkyWalking froze the network protocol a long time ago. In 7.0.0, we just
add new features to the protocol, but the old one is still working.

For backend upgrade, since 6.4.0, there is a reboot feature existing in
case you are doing the upgrade but erase the whole storage, which I don't
recommend.
Sheng Wu 吴晟
Twitter, wusheng1108
Zhang, James <[EMAIL PROTECTED]> 于2020年1月14日周二 上午9:28写道: