You need at least 5.2 or 5.3 to use SSL.
But if you at all care about security you should REALLY REALLY upgrade to latest version. Just check the list of fixed vulnerabilities and bugs.

--
Jan Høydahl, search solution architect
Cominvent AS - www.cominvent.com