Subject: ZooKeeper 3.4 end of life

  Bram Van Dam 2020-04-09, 09:28
  Erick Erickson 2020-04-09, 11:50
  Bram Van Dam 2020-04-09, 14:03
  Erick Erickson 2020-04-09, 14:26
  Bram Van Dam 2020-04-15, 08:19
  Erick Erickson 2020-04-15, 12:16
The problem with Solr related to use TLS with ZK is the following:
* 3.5.5 seem to only support tls certificate authentication together with TLS . Solr support es only digest and Kerberos authentication. However, I have to check in the ZK jiras if this has changed with higher ZK versions
* quorum tls will work but again only with tls authentication (not Kerberos etc). Again, one needs to check the ZK jiras which versions is affected and if this has been confirmed

If you don’t use TLS then zk in any version (potentially also ZK 3.6 - to be tested) should work. If you need TLS check if your authentication methods are supported.