Subject: Solr numFound > 0 but doc list empty in Solr Cloud setup


Anshuman,

You are right about @shards param not required. One of my shard was down and hence when I added
&shards.tolerant=true, it worked without shards param. However document list is still empty.
content of solrconfig.xml
http://pastebin.com/CJxD22t1

 
On Friday, January 16, 2015 1:24 PM, Jaikit Savla <[EMAIL PROTECTED]> wrote:
I followed all the steps listed here:
http://wiki.apache.org/solr/SolrCloud#Example_A:_Simple_two_shard_cluster

I have not updated solrconfig.xml and it is same as what comes default with 4.10.

The only thing I added extra was list of my fields in example/solr/collection1/conf/schema.xml

@shards: If I query with out that param, it returns below error:
http://localhost:9999/solr/collection1/select?q=*:*
<response>
<lst name="responseHeader">
<int name="status">503</int>
<int name="QTime">3</int>
<lst name="params">
<str name="q">*:*</str>
</lst>
</lst>
<lst name="error">
<str name="msg">no servers hosting shard:</str>
<int name="code">503</int>
</lst>
</response>


On Friday, January 16, 2015 12:37 PM, Anshum Gupta <[EMAIL PROTECTED]> wrote:
Looks like a config issue to me more than anything else.
Can you share your solrconfig? You will not be able to attach a file here
but you could share it via pastebin or something similar.
Also, why are you adding the "shards=http://localhost:8983/solr/collection1"
part to your request? You don't need to do that in most cases.
On Fri, Jan 16, 2015 at 12:20 PM, Jaikit Savla <
[EMAIL PROTECTED]lid> wrote:

Anshum Gupta
http://about.me/anshumgupta