clear query| facets| time Search criteria: .   Results from 41 to 50 from 10221 (0.0s).
Loading phrases to help you
refine your search...
[KNOX-1421] Enable OWASP Dependency Check - Knox - [issue]
... Please add OWASP Dependency Check to the build (pom.xml).  OWASP DC makes an outbound REST call to MITRE Common Vulnerabilities & Exposures (CVE) to perform a lookup for each dependant ...
http://issues.apache.org/jira/browse/KNOX-1421    Author: Albert Baker , 2018-10-05, 13:27
[KNOX-1431] Upgrade Jetty version to 9.3.10 - Knox - [issue]
...There is possible File Descriptor leak issue after EofException (https://github.com/eclipse/jetty.project/issues/634) in lower version of Jetty. So upgrading Jetty to 9.3.10 to fix the issue...
http://issues.apache.org/jira/browse/KNOX-1431    Author: Guang Yang , 2018-10-05, 13:24
[KNOX-1458] Support JDK 9/10/11 - Knox - [issue]
...This Jira is to track supporting JDK 9/10/11 for Apache Knox. With JDK 11 being released GA yesterday 9/25, we should see what needs to be investigated to make Apache Knox work....
http://issues.apache.org/jira/browse/KNOX-1458    Author: Kevin Risden , 2018-10-05, 13:22
[KNOX-1515] Upgrade shiro to 1.4.0 and ehcache to 2.6.11 - Knox - [issue]
...shiro 1.2.6 -> 1.4.0ehcache-core 2.5.0 -> 2.6.11...
http://issues.apache.org/jira/browse/KNOX-1515    Author: Kevin Risden , 2018-10-05, 13:19
[KNOX-1430] Potential output stream handle leak when copyLarge files in streamResponse - Knox - [issue]
...When Knox streams a large response, like download a 2G file through webhdfs. The output stream handle will leak if there is an exception when copy the large file. This fix move outputStream....
http://issues.apache.org/jira/browse/KNOX-1430    Author: Guang Yang , 2018-10-05, 13:04
[KNOX-1483] Evaluate gateway-provider-security-pac4j dependencies - Knox - [issue]
...While looking at KNOX-1456, I found that there are lots of dependencies pulled in for pac4j like Spring. Not sure all of these dependencies are necessary....
http://issues.apache.org/jira/browse/KNOX-1483    Author: Kevin Risden , 2018-10-05, 09:47
[KNOX-1513] Upgrade spring-core to 5.0.9.RELEASE - Knox - [issue]
...Due to KNOX-1509, spring-core needs to be updated to avoid known CVEs found with KNOX-1421....
http://issues.apache.org/jira/browse/KNOX-1513    Author: Kevin Risden , 2018-10-05, 09:47
[KNOX-1509] Upgrade pac4j dependencies - Knox - [issue]
...Upgrade: pac4j 2.1.0 -> 3.2.0 j2e-pac4j 3.0.0 -> 4.0.0Release notes: https://www.pac4j.org/docs/release-notes.html https://github.com/pac4j/j2e-pac4j/wiki/Release-Notes...
http://issues.apache.org/jira/browse/KNOX-1509    Author: Kevin Risden , 2018-10-05, 09:47
[KNOX-1514] Upgrade jackson to 2.9.7 - Knox - [issue]
...jackson 2.9.5 -> 2.9.7...
http://issues.apache.org/jira/browse/KNOX-1514    Author: Kevin Risden , 2018-10-04, 22:12
[KNOX-1484] Bump version dependencies Oct 2018 - Knox - [issue]
...There are a lot of dependencies that can be updated. Many are minor versions that should have no regressions. Subtasks will be created for each dependency so the change can be rolled back in...
http://issues.apache.org/jira/browse/KNOX-1484    Author: Kevin Risden , 2018-10-04, 22:11